Helpdesk Web Support Portal Unavailable.
Resolved
This incident has been resolved.
Posted Mar 01, 2023 - 10:44 GMT
Investigating
Freshdesk the provider of our support portal is having issues, resulting in us temporarily being unable to access tickets or raise new enquires. The team still have access to the telephones but there may be a delay in any written responses.
Posted Feb 28, 2023 - 11:07 GMT
This incident affected: Other (Helpdesk).